SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    P365 rounds don’t extract at times when slide cycled manually

Moderators: Chris Orndorff
Go
New
Find
Notify
Tools
Reply
  
P365 rounds don’t extract at times when slide cycled manually Login/Join 
Member
posted
Anyone have this issue? The gun is new and has maybe 20rds through it. It functioned 100% while shooting, but when cycling the slide manually, rounds sometimes don’t fully extract.

I have the FCU installed in a boresight solutions module, and the slide and barrel are stock. I installed a factory flat trigger myself.

I haven’t shot the gun yet to test anything.
 
Posts: 307 | Location: Keystone State | Registered: December 04, 2006Reply With QuoteReport This Post
Member!
posted Hide Post
Are you letting the slide drop full speed or riding it. The slide needs a certain slide speed for the timing of the round to chamber and slide under the extractor). If you ride the slide home or impede it in any way, the round will often "pop" out of the magazine (from magazine spring tension) in front of the extractor claw instead of "under" the claw hook. Then the slide might look closed and locked, but really won't be. So the next time you pull the slide, the round wont be pulled from the chamber since the claw has not engaged the cartridge rim. AS it works when shot, I'm assuming you're riding the slide..

Edit..You first say works 100% when shooting but then say you haven't shot it yet.. So whatever...
 
Posts: 4225 | Location: Boise, ID USA | Registered: February 14, 2003Reply With QuoteReport This Post
Member
posted Hide Post
Thanks for the response. I’m not riding the slide. I’m pulling the slide all the way back and letting go to load a round in the chamber.
 
Posts: 307 | Location: Keystone State | Registered: December 04, 2006Reply With QuoteReport This Post
Member!
posted Hide Post
Well then I'd stick the parts back onto the original frame module and see if it still exhibits the same behavior. If it doesn't then maybe the aftermarket module is goofy. If nothing else, I'd shoot it a bunch more first and the problem might go away on it's own since you don't have many or any rounds through it to break it in.
 
Posts: 4225 | Location: Boise, ID USA | Registered: February 14, 2003Reply With QuoteReport This Post
That's just the
Flomax talking
Picture of GaryBF
posted Hide Post
IMO, it happens because you are cycling the gun manually. It was designed to operate at full speed. Don't sweat the small stuff. Turn the gun over as you cycle the slide, if necessary to dump the round.
 
Posts: 11852 | Location: St. Louis, Missouri | Registered: February 04, 2008Reply With QuoteReport This Post
  Powered by Social Strata  
 

SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    P365 rounds don’t extract at times when slide cycled manually

© SIGforum 2021