SIGforum
MPX Issue???

This topic can be found at:
http://sigforum.com/eve/forums/a/tpc/f/630601935/m/6050027124

March 27, 2017, 08:22 AM
tinman4181
MPX Issue???
I have a factory MPX SBR. It was sealed in the box when I purchased it. I have noted that it appears the hammer is contacting the front of the lower receiver. So much so that it has pushed the metal in where the hammer rest. I can see the hammer being pushed back from the receiver when I pivot the upper receiver down on the lower, so it would be impossible for this to occur during normal firing. So my conclusion is that Sig has let the hammer fly at the factory with no bolt/upper in place.

Does anyone else have this mark on their lower and hammer? Should I be concerned? If you have an MPX can you post up a pic simular to mine so I can see the hammer and receiver area. Thanks in advance!


March 27, 2017, 12:23 PM
WARPIG602
If thats the only flaw youve found, Id say you're doing well. I wouldnt be concerned with it.


________________________________
March 27, 2017, 12:28 PM
rlex
Yes I have a similar loss of coating/finish....

I have had mine my MPX for over a year.....no problem


Retired US Naval Officer - Surface Warfare
MPX SBR
220
226 Mk 25
228
229 SCT
239
250c
320c FDE
P6
290 SR
Mosquito
March 27, 2017, 01:56 PM
SigP239Hokie
Same on my pistol (now SBR). The "issue" with the MPX lowers is the trigger springs have some good oomph to them. The thing that really bugs me is the charging handle cosmetic issue.



.
March 27, 2017, 07:06 PM
Graniteguy
Document it with Sig CS but I wouldn't bother sending it in unless it becomes worse.
March 30, 2017, 03:43 PM
rimshaker
I just got my factory SBR out of jail and I saw the same exact marks as your pic. Wouldnt exactly call it an issue.