SIGforum.com    Main Page  Hop To Forum Categories  The Lounge    Photographers, step in.

Moderators: Chris Orndorff, LDD
Go
New
Find
Notify
Tools
Reply
  
Photographers, step in. Login/Join 
Member
posted
I recently purchased a Nikon D5600 and a Sigma 18-200mm lens. I realized that the auto focus wasnt working when I tried them out. From what I have read on the internet, I need a firmware update on my lens.

Does anyone know how to do this? Is it something I can do myself or do I have to have it done somewhere? Not a lot of information out there.

Thanks in advance!
 
Posts: 467 | Location: Ohio | Registered: April 13, 2012Reply With QuoteReport This Post
Member
Picture of 4MUL8R
posted Hide Post
I suggest you browse the www.nikonians.org forum.


NRA Life Member
 
Posts: 3659 | Location: Commonwealth of Virginia | Registered: January 15, 2007Reply With QuoteReport This Post
Member
posted Hide Post
Nikon d5600 Firmware update download instructions are on the View Download Page.

I did not see any firmware updates for the lens listed on the Sigma firmware update website.


Hope this helps. The d5600 is a very well rated camera.

Silent
 
Posts: 703 | Registered: February 02, 2008Reply With QuoteReport This Post
Member
Picture of np149
posted Hide Post
Hi op. You can update the camera through Nikon’s website. It’s a straightforward process using one of your SD cards.

The lens on the other hand requires a Sigma USB dock. This is a piece of hardware from Sigma that attaches to the lens at the base (where the lens attaches to the camera).

You plug the USB end into your PC or Mac and then download a piece of software that will manage the firmware inside the lens.

The hardware runs about $60.00 new. You might be able to find someone who can loan you one or maybe your local camera shop can hook you up.

Good luck!
 
Posts: 211 | Location: Michigan | Registered: November 15, 2013Reply With QuoteReport This Post
Member
posted Hide Post
Thank you all. I will look in your the USB dock.
 
Posts: 467 | Location: Ohio | Registered: April 13, 2012Reply With QuoteReport This Post
That's just the
Flomax talking
Picture of GaryBF
posted Hide Post
quote:
From what I have read on the internet, I need a firmware update on my lens.

Are you sure the lens is not in manual mode?
 
Posts: 11766 | Location: St. Louis, Missouri | Registered: February 04, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Yes. Works fine on my d90 and d70. I have several nikkor lenses that work on the 5600, which is what led me to the firmware conclusion. Others have had the same problem with the 5500 and 5600.
 
Posts: 467 | Location: Ohio | Registered: April 13, 2012Reply With QuoteReport This Post
  Powered by Social Strata  
 

SIGforum.com    Main Page  Hop To Forum Categories  The Lounge    Photographers, step in.

© SIGforum 2020