SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    Need help reassembling P320....

Moderators: Chris Orndorff

Closed Topic Closed
Go
New
Find
Notify
Tools
Need help reassembling P320.... Login/Join 
Unapologetic Old
School Curmudgeon
Picture of Lord Vaalic
posted
I am trying to put a compact slide on a subcompact frame. For some reason I can't get the slide to move all the way to the rear so I can flip the taken down lever. I'm sure it's something stupid or a brain fart but I can't see anything blocking the way. It wil go on as far as normal slide position, but won't go past. I can feel it hitting something but when I look I don't see anything.


---------------------------------
- "This town reminds me of something in the bible."
- "Which part?"
- "The part right before god gets angry"
 
Posts: 7224 | Location: TN | Registered: December 18, 2005Report This Post
Member
posted Hide Post
I don't own any P320, but isn't there something about having the flats on the guide rod vertical?
 
Posts: 1240 | Registered: October 01, 2013Report This Post
Member
posted Hide Post
Check the guide rod position & compare the C & SC guide rods. Mine has different end shapes, on the SC the hole must face downward or it will catch as you described. Try making sure the hole is aligned, also you may have inadvertently switched the guide rods.


__________________________________________________

If you can't dazzle them with brilliance, baffle them with bullshit!

Sigs Owned - A Bunch
 
Posts: 3173 | Location: Nashville, Tennessee | Registered: December 16, 2004Report This Post
Gloom, despair and
agony on me.
Picture of drabfour
posted Hide Post
Is the guide rod spring assembly in the right position with the fatter end in the slide and the and the skinny on the barrel lug? I was at a gun shop one day and they were having the same problem come to find out they had it flipped. I don't know how they did it because I tried it on mine and it wouldn't go all the way on.

This message has been edited. Last edited by: drabfour,
 
Posts: 3983 | Location: Texas | Registered: July 22, 2008Report This Post
Unapologetic Old
School Curmudgeon
Picture of Lord Vaalic
posted Hide Post
I have the spring in the correct direction, and there is no flat on mine, its round.

I got it to rack back finally, but now a mag will not lock in place and the trigger isn't working


---------------------------------
- "This town reminds me of something in the bible."
- "Which part?"
- "The part right before god gets angry"
 
Posts: 7224 | Location: TN | Registered: December 18, 2005Report This Post
Gloom, despair and
agony on me.
Picture of drabfour
posted Hide Post
I'm sure you probably did but have you tried stripping it down again and reassembling it again?

Or tried it back on the compact grip?
 
Posts: 3983 | Location: Texas | Registered: July 22, 2008Report This Post
Fighting the good fight
Picture of RogueJSK
posted Hide Post
quote:
Originally posted by Lord Vaalic:
I have the spring in the correct direction, and there is no flat on mine, its round.

I got it to rack back finally, but now a mag will not lock in place and the trigger isn't working


Did you use the slide lock lever to lock the slide to the rear before flipping the takedown lever? When reassembling the P320, the slide lock lever must be used, in order to disengage the takedown safety.
 
Posts: 19084 | Location: Northwest Arkansas | Registered: January 06, 2008Report This Post
  Powered by Social Strata  

Closed Topic Closed

SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    Need help reassembling P320....

© SIGforum 2017