SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    Light trigger no strike

Moderators: Chris Orndorff
Go
New
Find
Notify
Tools
Reply
  
Light trigger no strike Login/Join 
Member
posted
I put a Apex trigger and bar on an older p320 with the heavy trigger on it. It worked before with the older trigger and bar. Now the trigger pull is very light and it doesn't fire! Any ideas?
TIA
 
Posts: 21 | Location: Adamstown Pa | Registered: October 25, 2020Reply With QuoteReport This Post
Member
Picture of sleepla8er
posted Hide Post
.

Other than lubrication issues or improperly installed parts...

Does your older P320 have the "Drop Safety" modifications?

Apex redesigned their components because of the P320 "Drop Safety" modifications performed by Sig. Are the Apex parts you've installed for a pre or post drop safety modified P320?

The Apex Over Travel Trigger Stop will not function in a P320SC.

If your P320 has a manual safety, the Apex Trigger Bar must be the version for a manual safety P320 and vice versa.

The people at Apex are very Customer focused, contact them (Phone: 623-322-0200 Email: guns@apextactical.com) and they will help if none of these items are causing your problem.

.
 
Posts: 2647 | Location: San Diego, CA  | Registered: July 14, 2009Reply With QuoteReport This Post
Member
posted Hide Post
Not sure about parts. I was trying to make it drop safe.
 
Posts: 21 | Location: Adamstown Pa | Registered: October 25, 2020Reply With QuoteReport This Post
  Powered by Social Strata  
 

SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    Light trigger no strike

© SIGforum 2021