SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    mag issue

Moderators: Chris Orndorff
Go
New
Find
Notify
Tools
Reply
  
mag issue Login/Join 
Member
posted
Sig 239 .40

Came with 2 mags. Both look good.
1 will not eject. Slide locked back, empty drops ok. Slide closed, Clicks but doesn't drop free.
New mags all ok both ways, so not the catch.

Any fixes or just trash it?
 
Posts: 1118 | Location: AZ | Registered: December 10, 2003Reply With QuoteReport This Post
Security Sage
Picture of striker1
posted Hide Post
Is one mag twisted? Any other deformations? Same base?



RB

Cancer (NHL) Survivor 2010 and 2014, now fighting Diffuse Large B Cell Lymphoma.

“Did you hear about the statistician who recently drowned in an average of 5 feet of water?”


 
Posts: 6630 | Location: Michiana | Registered: March 01, 2005Reply With QuoteReport This Post
Member
posted Hide Post
The body looks ok to me. No burrs or rub marks around the catch slots.
Feeds ok. Just ejection problem with this one.
 
Posts: 1118 | Location: AZ | Registered: December 10, 2003Reply With QuoteReport This Post
Security Sage
Picture of striker1
posted Hide Post
Maybe just disassemble that mag, clean, and reseat the spring and follower.



RB

Cancer (NHL) Survivor 2010 and 2014, now fighting Diffuse Large B Cell Lymphoma.

“Did you hear about the statistician who recently drowned in an average of 5 feet of water?”


 
Posts: 6630 | Location: Michiana | Registered: March 01, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

SIGforum.com    Main Page  Hop To Forum Categories  SIG Armorer    mag issue

© SIGforum 2018